Thursday, September 6, 2012

Recently we have migrated a SharePoint 2007 site [publishing site] to SharePoint 2010. The process was successful but while we are opening any ASPX in the pages library or Manage Content and Structure page it is giving below error.

"One or more field types are not installed properly. Go to List settings page to delete these fields."

Usually this error comes when we are trying to access a column which is not there in a list or library. But, in this scenario it is special and took lot of time to figure out what is the issue.

Tools used to find out the issue are:

  • SharePoint designer
  • SharePoint Manager
After looked deeply into all the lists/libraries and the pages, we found there are some hidden lists in the site. I first tried to deactivate and activate the Publishing feature in the site collection level, it was successful. And then trying to activate the publishing feature at root web level, it was failed. So, I clearly understood there is something wrong with publishing feature as everything else are working fine. 

After did some research and googled for the sometime, found that the list named "Relationships List" is causing the error. It will not migrate successfully most of the times when we migrate from 2007 to 2010.  Below is the solution for fixing it. 
  • Deactivate the "SharePoint Server Publishing Infrastructure" feature in SP 2010 server at site collection level.
  • Type http://sharepointserverurl/Relationships%20List/AllItems.aspx in the browser.
  • From List settings, delete this list.
  • Activate the publishing feature at site collection level.
If needed, you can activate the publishing feature at root web level as well. Once you followed the above steps the site should work without any issues as the "relationships list" is now created right. :)


Post a Comment