Tuesday, May 4, 2010

Today, when I installed the SharePoint 2010 server, First task I want to complete is user profile import. Everyone knows that there was a big bug in the BETA version in this module. So, I went there in manage services screen and clicked the "User Profile Synchronization Service". Surprisingly I got the error screen and don't know what to do. That is unspecified error screen and not given any error details.
But, we have an excellent resource to solve all these issues. I mean SharePoint Log files. When I went there and looked into the file, I found below exception message.

UserProfileServiceUserStatisticsWebPart:LoadControl failed, Exception: System.IO.FileLoadException: The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)     at Microsoft.Office.Server.UserProfiles.UserProfileConfigManager.InitializeIlmClient(String ILMMachineName, Int32 FIMWebClientTimeOut)     at Microsoft.Office.Server.UserProfiles.UserProfileConfigManager..ctor(UserProfileApplicationProxy userProfileApplicationProxy, Guid partitionID)     at Microsoft.SharePoint.Portal.WebControls.UserProfileServiceStatisticsWebPartBase.LoadControl(Object sender, EventArgs e)    74edaea3-11cb-44a8-af6b-b8dad2876437

Time god, I knew this issue earlier that there are couple of chances why it's coming.
  1. Check once that the Forefront Identity Manager Synchronization Service and the Forefront Identity Manager Service are running [Go to services and check].
  2. If Central Administration and the User Profile Synchronization service are provisioned on the same server then you should do IISRESET after started the service.
In my case, the problem was #1. After I started them and IISRESET everything started working fine.

9 comments:

  1. Thank you for the help - what a simple fix to a kind of intimidating error.

    ReplyDelete
  2. This was amazing, i had forgotten to do IISReset...Thanks...This helped me!

    Regards
    Vishwas Setty
    MCTS, MCITP SharePoint Server 2010

    ReplyDelete
  3. Thanks buddy u saved me some valuable time appreciate your help.

    ReplyDelete
  4. many thanks! solved my problem :)

    ReplyDelete
  5. Tried IIS reset, restarted all my machines, cleared the cache files. An yet there it is! The same error :(

    Any ideas on where I would have gone wrong?

    ReplyDelete
  6. Hi there,

    I have done all your suggestions. When I try to start Forefront Identity Manager Service I get an informational window that says "Windows could not star the Forefront Identity Manager Service service on Local Computer. Error 1053: The service did not responnd to the start or control request in a timely fashion."

    Where do I get the log to see what my error "an unexpected error occurred" is?

    Thank you,
    Kind Regards,
    Marli

    ReplyDelete
  7. Hi there,

    I have tried your suggestions.
    When I want to start the Forefront Identity Manager Service I get the following message "Windows could not start the Forefront Identity Manager Service service on Local Computer. Error 1053: The service did not respond to the start or control request in a timely fashion."

    Where do I find the log where I can see what "an unexpected error occurred" means?

    Thank you,
    Marli

    ReplyDelete
  8. We are having this issue with no luck. I am trying to turn on the Forefront Identity Manager services but they won't start and it's giving me an error "Error 1069: The service did not start due to a logon failure." I have reset IIS and the server...I've also fully configured the farm...no luck!

    ReplyDelete