Wednesday, November 4, 2009

SharePoint designer 2010 is not supporting backward compatibility. Means won't support Windows SharePoint Services v3 or earlier versions. I think you got what I am going to say now… Yes, SharePoint designer 2010 only works for SharePoint 2010. I think this news is hard for you, but this will be good for us only. Because in this way, they will build very good version of product without any mess-up. By taking this as the advantage they will only concentrate on the SharePoint 2010 support and will make really a very good product. So, how to get the support for SharePoint 2007 sites? Is there no other way to edit the earlier version sites? I know this is the question in your mind now.

Don't fear. There is an option. By thinking these questions in mind, the SharePoint designer team is developing the software/product to install the designer side by side. So, you can install the SharePoint designer side by side the both versions on the same machine without having any issues. So, this will solve all the problems. If any site which is of earlier than SharePoint 2010 you can use SharePoint Designer 2007, for SharePoint 2010 you can use SharePoint designer 2010.

Are there any requirements for side by side installation? Yes, it has some requirements. You know a big change from previous version to current version is bit [32 bit vs 64 bit]. As SharePoint Designer 2007 is came only on 32-bit[x86], you will only install SharePoint Designer 2010[X86] 32 bit version side by side on a server. And if you install SharePoint Designer 64-bit on a server which has installed 32-bit MS Office, then it won’t give good result. So, Don’t install mismatched version of any. Please install everything of same version.

2 comments:

  1. Hi,

    This artical is very useful for me. I am a Share Point developer and always looking to learn something new. I would like to introduce another good SharePoint blog, Have a look.

    http://SharePointBank.com
    Harry

    ReplyDelete
  2. Unfortunately if you install SPD 2007 next to 2010 and then try and open a document from a sharepoint 2007 content type it will fail.
    Installing SPD 2007 affects the owssupp and creates all kinds of problems when you want to use datasheet view, open content types etc etc in 2007

    nightmare!

    ReplyDelete